llvmlite 0.23.0のインストール中にエラーが出た時の対処法

torch 4.0をインストールしようとしたら、requirementのllvmlite0.23のインストールで以下のようなエラーメッセージが吐き出された。

g++: error: unrecognized command line option ‘-Wcovered-switch-default’
g++: error: unrecognized command line option ‘-Wstring-conversion’

例の如くネット検索すると、コンパイラーをg++からclang++に変えればこのエラーは解消されるみたいな情報を得たので、以下のようにそのネット情報通りにしてみた。

CXX=clang++ CC=clang pip3 install llvmlite==0.23.0

しかし、期待とは裏腹に、以下のようなエラーメッセージが吐き出された。

clang-6.0: error: linker command failed with exit code 1 (use -v to see invocation)
Makefile.linux:20: recipe for target 'libllvmlite.so' failed
make: *** [libllvmlite.so] Error 1
6.0.0

再びネットで検索すると、以下のようにすれば全く無問題とあった。

CXX=clang++ CC=clang CXX_FLTO_FLAGS= LD_FLTO_FLAGS= pip3 install llvmlite==0.23.0

半信半疑で試してみたが見事に問題が解決された。いや~、ネットって凄いですね。

参考サイトhttps://github.com/

スポンサーリンク